Back to overview
Degraded
Connection Issues
Feb 11, 2026 at 03:13pm UTC
Affected services
Invent App
Invent API
Resolved
Feb 11, 2026 at 04:33pm UTC
All systems are operating normally again.
Affected services
Updated
Feb 11, 2026 at 03:34pm UTC
Systems are recovering, we continue monitoring the situation.
Affected services
Created
Feb 11, 2026 at 03:13pm UTC
We're investigating with our hosting provider regarding an incident that is affecting most of our users.
Affected services