Back to overview
Resolved

Service disruption, restored, monitoring

Jul 18, 2026 at 8:41pm UTC
Affected services
Invent App
Invent API

Resolved
Jul 18, 2026 at 8:52pm UTC

The earlier service disruption has been fully resolved and everything is operating normally again.

Thank you for your patience.

Created
Jul 18, 2026 at 8:41pm UTC

Today between 4:14 PM and 4:41 PM ET, Invent was temporarily unavailable due to a technical issue at one of our infrastructure providers.

What you should know:

  • Your data is safe. Nothing was lost or altered.
  • No messages were missed. WhatsApp, Instagram, and Messenger messages sent during the downtime were delivered automatically once service was restored, and your AI assistants picked up right where they left off.
  • Service is back to normal. Our provider is finishing remediation on their end, and we're actively monitoring until they confirm full resolution.

We're sorry for the interruption and will share a follow-up once our provider completes their review.

Thank you for your patience.